LaunchPad issues for Monkey X (Mavericks)

Monkey Forums/Monkey Beginners/LaunchPad issues for Monkey X (Mavericks)

Boulderdash(Posted 2014) [#1]
I have successfully set MonkeyX up on my Windows computer, Now I'm setting it up on my MacBook running OS X Mavericks

Once I drag it from Downloads to Applications I get an extra unwanted Icon in "LaunchPad" called "MonkeyProXf" which I can't get rid of, I tried using "LaunchPad cleaner" but it reappears, its not relevant to anything, I can live with it , but its annoying me because I want it gone, but can live with it.

Is this normal for Monkey ?

marksibly(Posted 2014) [#2]
I never use launchpad, and Monkey is entirely 'self contained' (ie: it's just a dir with some stuff in it that doesn't touch anything outside it's own folder) so I have no idea what's going on.

It does sound like deleting stuff from launchpad can be tricky though, eg:

Boulderdash(Posted 2014) [#3]
Launch Pad is Mac equivalent of "Start>Programs" on Windows

Its definitely not a bug, but odd because I also have beebem and zxsp in the applications folder and they have a similar layout i.e.. just a folder containing other items similar to monkey.

Im a new Mac user but I have found that you can not install Monkey or Blitz Max just by downloading then dragging to the applications folder as I have done with beebem etc , I got it to work (without nuisance folders appearing in LaunchPad) by downloading then dragging from "downloads" folder to "home" folder then creating an alias (then renaming alias back to Monkey) then moving Alias (i.e.:shortcut) to "Applications" folder, problem solved, no folders in LaunchPad

It seems that Launch Pad creates those folders because there are executables in them

Something that could help make things go smoother is that Ant etc version numbers in config file are out of date.

Oddball(Posted 2014) [#4]
Sometimes if you move an app to the trash it'll stay in launch pad but can't be launched. Not sure if that's your exact problem but you could try emptying the trash can just in case.

Boulderdash(Posted 2014) [#5]
I tracked the problem to Launch Pad finding the Executable files in the sub folders, problem solved by moving Monkey & Max to my home folder and putting shortcuts (alias's) in the Applications folder instead.