Jungle GUI events not working?

Monkey Forums/Monkey Beginners/Jungle GUI events not working?

narcea(Posted 2015) [#1]
When I add an event to the button I get a "Could not generate an Event Callback" error. If I remove the event_click the program runs fine. I get the same error when I run the Jungle GUI sample1.monkey source. Can anyone shed some light? Is it a problem with my Reflection Filter.

I have pasted the relevant parts of the code:

narcea(Posted 2015) [#2]
I fixed it. The Method 'Method Event_Clicked' should have been 'Method Button_Clicked'. I'm not sure why Sample1 didn't work but I tried a different copy of it and it did.

narcea(Posted 2015) [#3]
No I didn't fix it. I mean I got the button working (sort of) but it's not the reason my program is crashing. I upgraded from MonkeyXPro81b to MonkeyXPro82b. My program crashes when it's compiled under 82b but not 81b!?
The crash is as reported above, "Could not generate an Event Callback. The Method Button_Clicked... was not found.".

On top of this I got a message that an Update to Monkey X Studio is available (15.03-11). So I go "Yeah they fixed it!!" Right? No! This update crashes with a "Jungle Ide Runtime Error: The specified executable is not a valid application for this OS platform.".

Help? Anyone?

narcea(Posted 2015) [#4]

narcea(Posted 2015) [#5]
I changed the Monkey location in the Jungle IDE to point to 81b and it works. Returning it to 82b it fails. So I'll leave it on 81b but I'd like to use the newer version... is this a known bug in the last release?

ziggy(Posted 2015) [#6]
1.- The updating issue can be caused by a connection problem. It seems the update "exe" downloaded corrupted. If that happens to you again, you can download the update directly from your account here (on product updates). What's your OS version and architecture?

Now, regarding Jungle Gui:
I think it *may* be a reflection bug in latest Monkey version.
I've moved the whole Jungle Gui repository to github, so it may be easier to make pull requests, but anyway, if you can provide a very simple and short sample that replicates the issue, I'll be happy to try to fix it, or report the bug here if it's (as it seems) a Monkey compiler bug. However, version 81 is very stable, you could stick to that version untill we can provide a reliable fix for this unknown issue.

EDIT: Confirmed there's a reflection bug in latest Monkey versions, I've already placed a bug report. I hope mark fixes it.

narcea(Posted 2015) [#7]
Thanks Ziggy. I'm running the 64 bit version of Windows 7.